s390 architecture · Supported
Maintainers
- M Heiko Carstens <hca@linux.ibm.com>
- M Vasily Gorbik <gor@linux.ibm.com>
- M Alexander Gordeev <agordeev@linux.ibm.com>
- R Christian Borntraeger <borntraeger@linux.ibm.com>
- R Sven Schnelle <svens@linux.ibm.com>
Paths
- F
Documentation/driver-api/s390-drivers.rst - F
Documentation/arch/s390/ - F
arch/s390/ - F
drivers/s390/ - F
drivers/watchdog/diag288_wdt.c
Last 30 days
Active reviewers (last 30 days)
-
David Hildenbrand <david@kernel.org>
1 attestation (1 Suggested-by) · last on 2026-06-08 -
Magnus Lindholm <linmag7@gmail.com>
1 attestation (1 Acked-by) · last on 2026-06-08 -
Greg Ungerer <gerg@linux-m68k.org>
1 attestation (1 Acked-by) · last on 2026-06-08 -
Gregory Price <gourry@gourry.net>
1 attestation (1 Reviewed-by) · last on 2026-06-08
Recent patches
Most-recent 30 patches in this subsystem on virtualization (capped at 30), ordered by date desc.
-
COLD15d
[PATCH v1] s390/virtio_ccw: Also suppress -EINVAL on device detach
2026-06-12 · William Bezenah <hidden> -
COOLING9d
REVIEWED: 3 (3M) [PATCH v10 14/37] mm: remove arch vma_alloc_zeroed_movable_folio overrides
2026-06-08 · "Michael S. Tsirkin" <mst@redhat.com> -
COLD30d
REVIEWED: 3 (3M) [PATCH v9 14/37] mm: remove arch vma_alloc_zeroed_movable_folio overrides
2026-05-29 · "Michael S. Tsirkin" <mst@redhat.com> -
COLD21d
[PATCH 09/11] treewide: Convert custom kernel_param_ops .get callbacks to seq_buf via cocci
2026-05-21 · Kees Cook <kees@kernel.org> -
COLD21d
[PATCH 04/11] treewide: Convert struct kernel_param_ops initializers to DEFINE_KERNEL_PARAM_OPS
2026-05-21 · Kees Cook <kees@kernel.org> -
COLD30d
REVIEWED: 3 (3M) [PATCH v8 14/37] mm: remove arch vma_alloc_zeroed_movable_folio overrides
2026-05-20 · "Michael S. Tsirkin" <mst@redhat.com> -
COLD47d
REVIEWED: 2 (2M) [PATCH v7 11/31] mm: remove arch vma_alloc_zeroed_movable_folio overrides
2026-05-12 · "Michael S. Tsirkin" <mst@redhat.com> -
COLD50d
REVIEWED: 2 (2M) [PATCH resend v6 08/30] mm: remove arch vma_alloc_zeroed_movable_folio overrides
2026-05-11 · "Michael S. Tsirkin" <mst@redhat.com> -
DORMANTno replies
REVIEWED: 2 (2M) [PATCH v6 15/30] mm: remove arch vma_alloc_zeroed_movable_folio overrides
2026-05-11 · "Michael S. Tsirkin" <mst@redhat.com> -
COLD51d
REVIEWED: 2 (2M) [PATCH v6 08/30] mm: remove arch vma_alloc_zeroed_movable_folio overrides
2026-05-11 · "Michael S. Tsirkin" <mst@redhat.com> -
STALE65d
REVIEWED: 2 (2M) [PATCH RFC v4 12/22] mm: remove arch vma_alloc_zeroed_movable_folio overrides
2026-04-26 · "Michael S. Tsirkin" <mst@redhat.com> -
STALE66d
[PATCH RFC v3 10/19] mm: remove arch vma_alloc_zeroed_movable_folio overrides
2026-04-21 · "Michael S. Tsirkin" <mst@redhat.com> -
STALE71d
Re: [PATCH RFC v2 11/18] mm: skip zeroing in vma_alloc_zeroed_movable_folio for pre-zeroed pages
2026-04-21 · "David Hildenbrand (Arm)" <david@kernel.org> -
STALE88d
[PATCH 10/12] s390/ap: use generic driver_override infrastructure
2026-03-24 · Danilo Krummrich <dakr@kernel.org> -
STALE88d
[PATCH 09/12] s390/cio: use generic driver_override infrastructure
2026-03-24 · Danilo Krummrich <dakr@kernel.org> -
STALE89d
[PATCH 6/8] KVM: use rest_of_page() macro where appropriate
2026-03-04 · Yury Norov <hidden> -
STALE89d
[PATCH 3/8] net: use rest_of_page() macro where appropriate
2026-03-04 · Yury Norov <hidden> -
STALE215d
LANDED: 2 (2M) [PATCH v2 18/22] vfio/ccw: Convert to get_region_info_caps
2025-11-07 · Jason Gunthorpe <jgg@nvidia.com> -
STALE215d
LANDED: 2 (2M) [PATCH v2 12/22] vfio/ccw: Provide a get_region_info op
2025-11-07 · Jason Gunthorpe <jgg@nvidia.com> -
STALE236d
[PATCH 18/22] vfio/ccw: Convert to get_region_info_caps
2025-10-23 · Jason Gunthorpe <jgg@nvidia.com> -
STALE236d
[PATCH 12/22] vfio/ccw: Provide a get_region_info op
2025-10-23 · Jason Gunthorpe <jgg@nvidia.com> -
STALE253d
[PATCH] mm: Make INVALID_PHYS_ADDR a generic macro
2025-10-21 · Anshuman Khandual <hidden> -
STALE265d
REVIEWED: 13 (11M) [PATCH v2 03/37] s390/Kconfig: drop superfluous "select SPARSEMEM_VMEMMAP"
2025-09-01 · David Hildenbrand <hidden> -
STALE303d
REVIEWED: 11 (11M) [PATCH v1 03/36] s390/Kconfig: drop superfluous "select SPARSEMEM_VMEMMAP"
2025-08-27 · David Hildenbrand <hidden> -
STALE265d
[PATCH RFC 03/35] s390/Kconfig: drop superfluous "select SPARSEMEM_VMEMMAP"
2025-08-21 · David Hildenbrand <hidden> -
STALE317d
[PATCH] mm/numa: Rename memory_add_physaddr_to_nid to memory_get_phys_to_nid
2025-08-18 · <hidden> -
STALE348d
[PATCH 1/2] crypto: engine: remove request batching support
2025-07-11 · Ovidiu Panait <hidden> -
STALE446d
LANDED [PATCH v1] s390/virtio_ccw: don't allocate/assign airqs for non-existing queues
2025-04-02 · David Hildenbrand <hidden> -
STALE492d
[PATCH v2 05/13] cpumask: deprecate cpumask_next_wrap()
2025-01-28 · Yury Norov <yury.norov@gmail.com> -
STALE532d
[PATCH 05/14] cpumask: deprecate cpumask_next_wrap()
2024-12-28 · Yury Norov <yury.norov@gmail.com>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE89d
[PATCH 3/8] net: use rest_of_page() macro where appropriate
2026-03-04 · Yury Norov <hidden> -
STALE89d
[PATCH 6/8] KVM: use rest_of_page() macro where appropriate
2026-03-04 · Yury Norov <hidden>